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1. Introducing Idea Cruncher
Idea Cruncher is a simple program for gathering thoughts and organizing projects.  
A common quality of most projects is that they can be (more like need to be) 
divided into sub-projects, and sub-sub-projects, and so on.  This is true whether 
the final product is a research paper, a website, a software program or a beautifully 
renovated kitchen. Big, daunting projects are broken down into smaller, more 
manageable projects, and ultimately, into “actions,” the individual steps that we 
must perform to accomplish the project. (For more on this, see David Allen’s 
book, Getting Things Done: The Art of Stress Free Productivity.)  Idea Cruncher is 
designed to help keep track of the sub-projects and actions required to accomplish a 
big project.

Doubleclick the Idea Cruncher icon on the desktop, or choose the Idea Cruncher 
shortcut from the start menu, and you should see a window with three main sections 
as shown here: 

The top-left section is where most of the organization work is done.  It has a box for 
entering new ideas and a tree that holds all of the ideas in your hierarchy.

Immediately to the right of the tree is a notes section (with a light blue title area) for 
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holding plain text notes about the currently selected idea in the tree.  This section 
can contain any text, for example, the details that you want to remember about that 
idea, or a rough draft of the text you want to use to express that idea.

The bottom of the window is multipurpose.  For writing projects, you can use it 
to work on a refined draft of your document, while referring to the tree and your 
notes (see the section below called “Using Idea Cruncher for Writing”).  For other 
projects, you can show a list of the ideas that you have identified as “actions” – a 
convenient to-do list (see “Using Idea Cruncher for Managing Projects”).  Finally, 
the bottom section is also used for searching (see “Finding Text”).
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2. Entering Ideas
Click on the “New Idea” box in the top left section of the Idea Cruncher window.  
Type something:

When you hit enter, you will see the new idea move into the tree below, under the 
“Title” item:

The New Idea box is empty again, waiting for your next idea.  If you continue to 
type and hit enter, you will get a simple list under the “Title” item:

Suppose you want to add another level of detail underneath one of the ideas you 
just entered.  Just click on the blue icon next to that idea and it will change from 
dark blue to light blue.  This indicates that new ideas will be inserted under this 
idea.  Now click in the New Idea box.  New ideas will be placed under the idea you 
selected:
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You can continue adding ideas and new levels of detail until you are satisfied.

Finally, let’s change the “Title” to something meaningful.  Select the Title idea then 
click on the text to rename it, the same way you would rename a file.  Press enter 
when you’re done.  You can change the text on any idea this way:

3. Associating Notes with an Idea
The notes section to the right of the tree control holds plain-text notes for the 
currently selected idea.  As you click on different ideas in the tree, the contents of 
the notes section will change to show the notes that you have entered for that idea.  
Of course, for all new ideas, the notes section will initially be empty.  Click on 
any idea in the tree, click on the notes section, then type whatever text you want to 
associate with that idea.  If you click on a different idea after you enter some text, 
the notes section will change to reflect the text for the newly selected idea.  Click 
back on the original idea and you will see that your notes are still there.
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4. Keeping Track of Important Websites
In addition to text, the notes section can also hold clickable links to websites.  It 
will automatically recognize a website address and convert it to a blue, underlined 
hyperlink.  When you click on a link, your default browser will be started if 
necessary and sent to that location.

5. Manipulating Ideas
As soon as you have entered a small number of ideas into the tree, you will usually 
begin asking yourself questions about the way you have represented the ideas 
and their relationships to eachother.  You will probably want to change the way 
some ideas are worded or their positions in the tree; others you will want to delete 
altogether.  The next few sections cover these actions.

6. Editing Ideas
You can change the text on any idea in the tree.  First, select the idea with the 
mouse or the up-and-down arrow keys.  Then click directly on the text, or choose 
Edit > Rename, or right click on the text and choose Rename.  When you do any of 
these things, an edit box should appear around the text, allowing you to edit it in-
place.  When finished editing, just click anywhere outside the text or hit enter for 
the change to be confirmed.

7. Deleting Ideas
The delete key on the keyboard will delete the currently selected idea and all of its 
child ideas in the tree.  To undo an accidental deletion, immediately choose Edit > 
Undo or type Ctrl+Z.

8. Moving and Copying Ideas
You can move individual ideas around in the tree to improve the logic and flow 
of your outline.  You can also make a copy of an idea at a different location in the 
tree. There are a few different ways of completing these actions: drag-and-drop, 
copy-and-paste, and the Move Idea commands in the Tools Menu.  If the idea you 
are moving or copying has any children in the tree, they are moved or copied at the 
same time.
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Drag-and-Drop
The most direct way to move an idea is to pick it up with the left mouse button and 
drag it to the desired new location.  If you drop an idea directly on top of another 
idea, it will become the first “child” of that idea.  If instead, you drop the idea in the 
small space between two “sibling” ideas, the idea will be inserted between the two 
siblings.  A red line appears between the two siblings when you are positioned in 
the space between them.  In the example below, the “crackers” idea will be placed 
between “oranges” and “cheese.”

If you hold the Ctrl key down while you are dragging, the operation becomes a 
copy instead of a move: a copy of the idea is inserted at the drop location while the 
original stays at its location in the tree.  If you pick up the wrong item and want 
to cancel the drag-and-drop operation, and you are still holding the mouse button 
down, just hit escape and then release the mouse button.

Copy-and-Paste
Ideas can also be cut or copied to the Windows clipboard, using the standard 
commands on the Edit Menu.  As with drag-and-drop, any children of the selected 
idea are put on the clipboard as well, and the structure between them is maintained 
on the clipboard.  A cut command causes the selected idea to be removed from the 
tree when it is put on the clipboard, while a copy command leaves the original idea 
intact.  After cutting or copying the idea, select the idea’s new parent in the tree 
control and choose the Paste command.  You should immediately see the idea you 
cut or copied as the first child of the new parent idea.

Move Idea Commands (Tools Menu)
The Tools menu has four commands that move ideas relative to their siblings in the 
tree.  All movements are relative to the selected idea’s siblings.  Choose “Up” to 
move the selected idea up one position in the list of siblings, “Down” to move the 
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idea down one position, “To Top” to make the idea the first sibling in the list, and 
“To Bottom” to move it to the bottom of the sibling list.  These commands have 
equivalent buttons on the toolbar:

9. Zooming in on a Portion of the Outline
As the number of ideas in the tree grows, you will probably want to focus on a 
particular section and ignore everything else.  The “zoom in” command temporarily 
hides everything in the tree except the selected idea and its children.  To zoom, 
select the idea you want to focus on and choose “Zoom In” from the View menu.  
You can also right-click the idea and choose the same command from the context 
menu.  At that point, the selected sub-tree will be the only thing visible in the tree.  
You can do anything to this sub-tree that you would normally do to the tree.  When 
you are finished, choose “Show All” from the View menu, or the context menu, or 
the “Show All” button that automatically appears in the top right corner of the tree 
whenever you zoom in:

After selecting “Show All” you will see the entire tree again, including any changes 
that you made to the sub-tree while it was zoomed.

This zoom feature can be quite helpful for planning any kind of project, especially 
when the sheer number of ideas starts to get overwhelming and interferes with your 
creativity.  You will often want to focus on one section of a project to brainstorm 
or organize ideas just in that section.  Similarly, when working on an outline for a 
piece of writing, it can be helpful to focus on one section or even one paragraph, 
temporarily excluding everything else from consideration.  The zoom command 
provides this set of “blinders” to help you concentrate your attention when you need 
to, while keeping the rest of your ideas close at hand, just a click away.
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10. Checking Off Ideas
Keeping track of what you have finished and what you have still to do is a time-
honoured part of to-do list management, which usually involves drawing a 
satisfying line through the finished items.  You can mark any idea as finished by 
selecting it and choosing Edit > Completed or by right clicking it and choosing 
“Completed” from the context menu.  When you do, the blue icon to the left of 
the idea will get a white checkmark and the idea itself will get a (satisfying) line 
through it:

11. Printing
You can print the entire outline by choosing File > Print.  To print just a portion of 
your ideas instead of the whole outline, choose File > Print Selected Idea, which 
will print the currently selected idea and its children, including any notes.  You can 
also right click an idea and choose “Print Selected Idea” to get the same result.

If you are working on a writing project and have been making a rough draft in the 
bottom section, you can print just the draft by moving the cursor into the bottom 
section and choosing File > Print.  You can also choose the printer button on the 
bottom section’s toolbar.

12. Finding Text
To search for a particular word or phrase in your outline, choose Edit > Find or 
type Ctrl+F.  When you do, the bottom section will be temporarily replaced by 
Find controls.  Type the text that you would like to find into the edit control and 
click the Find button or hit the Enter key.  If you would like to search for a phrase, 
enclose it in quotes.  Searching is not case-sensitive.  If you type more than one 
word or phrase (separated by spaces), all of the words or phrases must be found 
somewhere in the idea (tree or notes) to be considered a match.  All of the matches 
are displayed in a list below the search terms.  Each idea that has matching text is 
displayed with blue underlined hyperlinks on the matching text.  Click the hyperlink 
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to go to the idea where that text was found.

When you are finished searching, click the Close button or hit escape to make the 
Find controls disappear and restore the bottom section to its previous state.

13. Copying the Tree to other Software
You can bring any part of the tree into a software program (e.g., word processor) 
that supports pasting “rich text format” from the clipboard.  Start by selecting the 
idea in the tree at the top of the portion that you want to copy.  Choose Edit > Copy, 
switch to the destination software and choose its Paste command.  You should see 
a text version of the selected idea and all of its children in the destination window.  
You should be able to accomplish the same result in one step by dragging the 
selected idea from the tree and dropping it in the other software window.

14. Using Idea Cruncher for Writing
The features in Idea Cruncher are definitely designed to help with the writing 
process.  Like other types of projects, there are initially usually a ton of ideas 
coming into your head in more-or-less random order.  You can capture these ideas 
as they come to you and reorganize as you go.

When you start reorganizing after the initial brainstorm, it usually helps to start big 
and gradually work the outline down into finer levels of detail. These first items 
might represent the major sections of the document. The more detailed ideas can be 
added directly to the section you believe they will ultimately be found by dragging 
and dropping ideas with the mouse, or using the cut and paste commands.

As you continue to refine, try to think of each top-level entry as a section, and each 
second-level entry as a paragraph within its section. Third-level items are individual 
ideas to include inside the paragraph. Check for logic and flow, and move ideas 
around until you are happy with the overall outline.

Write the first draft of each paragraph in the notes section associated with the 
paragraph entry in the tree. That is, click on a (second-level) item in the tree that 
represents a paragraph, and write a draft of that paragraph in the notes section on 
the right side of the window. Refer to any third-level ideas that you have made for 
inclusion in that paragraph as you go. Organization problems that become apparent 
at this stage of the process can still be dealt with by moving ideas around in the tree. 
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You can print the outline with corresponding notes at any point in the process to see 
how the paragraphs are fitting together.

These draft paragraphs are essentially the first draft of your document, but they 
are stored separately from eachother in individual notes entries. You can produce 
a second draft by rewriting each paragraph in the draft section at the bottom of the 
window. Start by selecting the first paragraph in your outline and looking at the 
corresponding rough paragraph in the notes section. Move to the draft section at the 
bottom of the window and rewrite the paragraph there. (If the paragraph is perfect, 
you can just copy it with the copy and paste commands, but retyping usually 
improves the writing.) When you are finished with that paragraph, click on the next 
one in the tree. While the notes section changes to reflect the notes for the currently 
selected idea, the draft section remains constant, making it possible for you to 
construct your entire document there, paragraph by paragraph.

When you are finished with the rewriting process, the draft section should contain 
a complete second draft of the document. At that point, you can copy the contents 
of the draft section to your word processor and work on it there, or you can keep 
editing right in the draft section.

The Zoom command on the View menu can be useful, especially in the early parts 
of the writing process, if you want to temporarily focus on a portion of your outline 
without being distracted by the other parts. This command can usually clear the mist 
away if the outline is getting overwhelming.

15. Using Idea Cruncher for Managing Projects
Every project is different, but there are common elements to most projects.  If 
you are a fan of David Allen’s book, Getting Things Done: The Art of Stress Free 
Productivity, you probably automatically divide projects down into manageable 
sub-projects and then actions.  One of the most helpful suggestions in that book 
relates to the need to explicitly identify the actions required to accomplish a project.  
Important but often overlooked, planning down to the level of individual actions 
can eliminate a great deal of wasted time, effort and project anxiety.

Idea Cruncher includes the ability to identify particular ideas in the tree as actions.  
Select the idea you want to change into an action and choose Edit > Action, or right 
click the idea and choose Action from the context menu.  When you do, the blue 
icon will change into an orange arrow:
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You can change an action back into a regular idea by selecting it and choosing Edit 
> Idea or by right clicking it and choosing “Idea” from the context menu.

To see all of your actions grouped together in a list, choose View > Action List.  The 
bottom section will change to show the list of actions from the tree:

The actions appear in the order that they appear in the tree.  The action list contains 
all of the action items in the tree, regardless of where they occur.  If you want to 
see just the actions associated with a particular part of the tree, zoom in on that idea 
in the tree using View > Zoom In.  When you do, the list of actions in the bottom 
section will be shortened to show only those actions under the zoomed idea.  When 
you click the “Show All” button to unzoom, the action list will expand again to 
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show all of the actions.

To quickly find the location of an action in the tree, just double-click it in the action 
list.

You can mark an action as completed the same way you mark any other idea as 
completed using Edit > Completed.  The orange icon will get a white checkmark 
and the text of the action will get a line through it.  When an action is marked as 
completed, it disappears from the action list so that the list only contains the actions 
that you haven’t done yet.

16. Changing the Font
Choose Tools > Master Font to set the font for all sections of the Idea Cruncher 
window (except the draft text section, which has its own controls for setting font).

17. Moving or Copying Parts of the Tree 
between Idea Cruncher Files
Importing and exporting refers to the processes of moving or copying portions 
of your outline from one Idea Cruncher window to another.  You can import any 
.idc file into another running instance of Idea Cruncher.  In the destination copy of 
Idea Cruncher, select the idea where you want the other file’s tree to appear and 
choose File > Import.  Select the desired .idc file from the Open File dialog box that 
appears.  You should see the other file’s tree appear under the selected idea.

You can also export any portion of a tree into a new .idc file using the File > Export 
command.  After exporting, you will be able to open the new .idc file in its own 
Idea Cruncher window.

Finally, if you have two Idea Cruncher windows open, each with its own .idc file, 
you can freely drag-and-drop or copy-and-paste sections of the outlines between the 
two trees.



14

18. Taking Idea Cruncher with You on 
Removable Media
Registered users of Idea Cruncher are permitted to create a copy of the Idea 
Cruncher program on removable media such as a USB Flash Drive.  This program, 
called Cruncher.exe, will only run from removable media – it is not possible to 
copy it to a harddrive or network server and run it from there.  The purpose of this 
removable version is to permit users to take their .idc files with them from computer 
to computer without having to install Idea Cruncher on every computer they use.

To create the removable version, make sure the portable device is attached to the 
computer and select the “Create Portable Version” command from the Tools menu.  
When prompted, select the drive corresponding to the removable device.  After a 
short pause, you should receive a confirmation message indicating that the portable 
version was created on the selected drive.  From that point on, it should be possible 
to connect the portable device on any compatible computer and run Cruncher.exe 
from the portable device.  This portable version is functionally the same as the full 
harddrive installation of Idea Cruncher, except that it does not have the “Create 
Portable Version” command in its Tools menu.  Also, it will be necessary to run 
Cruncher.exe and then open the desired .idc file (instead of just doubleclicking the 
.idc file itself) if Idea Cruncher is not installed on the computer’s harddrive.
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